Z-axis doesn't decelerate at the negative soft limit.

Z-axis doesn't decelerate at the negative soft limit.

Postby flyingpickles » 02 Jul 2016, 12:48

Hello I have a problem with the Z-axis on my machine. The problem is that the Z-axis do not decelerate when it comes to the soft limit at Z 0 when I am jogging the axis. Instead it stops suddenly like it had been hitting a wall and it locks up all the other axis and it self too. To unlock all the axis I have to press up the emergency stop and go to: File, Settings, Limit and press OK (I don´t have to do any changes in the limit settings, just go there and press OK). Notice that I can not do this in the opposite way (go to limit and press OK and then press up the emergency stop, if I do so I have to go to Limit and press OK again to unlock the axis). Notice also that I have all the boxes unchecked in the Limit-settings.

I suspect that it has something to do with the software because I have change the Z-axis from the axis which goes up and down like it use to be on a mill to the axis which use to be the Y-axis on a mill (I have swaped Y and Z to make it the same as in 3D modeling software). I had the same problem before for the axis which then was the Z-axis but now is the Y-axis.

All other axis works exactly as I wish when I jogging them and Z works fine in the upper soft limit (1870) it is just Z 0 witch acts strange.

I have gone through all my settings and I don´t find anything that feels odd with the Z-axis... Please help me with this problem!

best regards: Flyingpickles
flyingpickles
 
Posts: 25
Joined: 28 Jul 2015, 17:54
Controller: Mk2

Re: Z-axis doesn't decelerate at the negative soft limit.

Postby Support » 04 Jul 2016, 13:39

Please post your latest settings file. Could you please try latest BETA version?
http://planet-cnc.com/software/

Can you take a picture of your machine and maybe video of occurrence?
Support
 
Posts: 2609
Joined: 07 Apr 2014, 17:39
Controller: Many controllers

Re: Z-axis doesn't decelerate at the negative soft limit.

Postby flyingpickles » 01 Sep 2016, 11:24

Hello and sorry for the late reply but here comes the settings file and a link to a video of the machine and how it acts.
I downloaded the latest version of the software:
SW: 2.10.1607.101
HW: 2014.11.03
SN: 1753 CNC
https://www.youtube.com/watch?v=y1Sv5m8 ... e=youtu.be

best regards: Flyingpickles
Attachments
2016-09-01_Z axis acts strange.setting
(50.58 KiB) Downloaded 41 times
flyingpickles
 
Posts: 25
Joined: 28 Jul 2015, 17:54
Controller: Mk2


Return to Mk2 controller



Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest

cron