Speed problem with circles and splines

Speed problem with circles and splines

Postby anode » 01 Sep 2016, 16:24

Hi
I'm using MK1 on an K2CNC machine ( gekodrives)
I have the following problem:
Speed varies during a circle ( or splines), for example from setted 500 up to 1780.
In attachement my settings and a test circle
Speed increases at north and south part of the circle.
Thanks in advance for support


settings0109sera.setting
(50.59 KiB) Downloaded 76 times

testpattern.tap
(21.36 KiB) Downloaded 55 times
anode
 
Posts: 7
Joined: 25 Jun 2012, 11:33
Controller: Mk1

Re: Speed problem with circles and splines

Postby Support » 02 Sep 2016, 10:27

You are using Mk1 controller which is under powered and outdated.
Can you post pictures of your controller?
Support
 
Posts: 2609
Joined: 07 Apr 2014, 17:39
Controller: Many controllers

Re: Speed problem with circles and splines

Postby brummettm58 » 02 Feb 2017, 22:57

What did you do to fix this issue? My speed doubles or triples at both North & South ends of circles and squares. When the speed increases, it causes my circle to shift sideways about 5/8". Everywhere else it runs great. Why is this happening?
brummettm58
 
Posts: 4
Joined: 22 Jan 2017, 03:45

Re: Speed problem with circles and splines

Postby Support » 03 Feb 2017, 11:30

Please post your settings and your g-code.
Support
 
Posts: 2609
Joined: 07 Apr 2014, 17:39
Controller: Many controllers

Re: Speed problem with circles and splines

Postby brummettm58 » 01 Mar 2017, 23:28

Here is the settings file. I did "something" and it's stop shifting sideways (for now anyway), bu tmy speed still varies and is uncontrollable.
Attachments
MKB Settings Modified.setting
(49.84 KiB) Downloaded 17 times
brummettm58
 
Posts: 4
Joined: 22 Jan 2017, 03:45


Return to Mk1 controller



Who is online

Users browsing this forum: No registered users and 1 guest