G-code error when opening Vcarve file

CNC USB Controller Software

G-code error when opening Vcarve file

Postby Ryadia » 15 Apr 2017, 01:14

Hello all.
I'm new to CNC control but a well experienced machinist. I'm starting to be thankful I waited 30 years to get involved with CNC. If I was in business I'd be close to broke with the drama I've been having. I hope some kind person can help me here. I'll be eternally grateful.

I've got an error message from CNC USB when opening a Vcarve file to machine a 6mm square (roughly) running 175mm the full length of piece of pine. Yes... I know I could do this in about 20 seconds with my router table but I'm doing this as a learning experience. Unfortunately my ability to retain what I learn is not what it used to be. Either that or this software has got gremlins in it!

The error is:
Bad character Đ (19) Line:1 ĐĎ◀ŕ±→á
Looks to me like a damaged file but if it was, why does Vcarve open it without drama? The whole idea of doing this "cut a straight line" exercise is to help understand Vcarve and then CNC USB. Not doing too well so far I'm afraid.
Ryadia
 
Posts: 6
Joined: 15 Apr 2017, 00:34

Re: G-code error when opening Vcarve file

Postby JerryBurks » 18 Apr 2017, 15:20

Might be that you are using the wrong Post Processor in Vcarve. You can choose that in the toolpath export dialog. Select any of the generic Post Processors that starts with "G-Code****". Does not matter if mm or inch but if you have arcs or circles in your design choose the variant that include "arcs".

I use Vcarve with Planet-CNC controller all the time, no problem.

Edited to say: Or are you trying to open the actual Vcarve file with Planet CNC? That will never work. You must generate a G-Code file in Vcarve that can be read by Planet-CNC.
JerryBurks
 
Posts: 217
Joined: 10 Jan 2012, 20:26
Location: Pasadena, California
Controller: Mk2

Re: G-code error when opening Vcarve file

Postby Ryadia » 18 Apr 2017, 22:51

Thanks for replying Jerry,
I did indeed try to open the actual Vcarve file. Where I got it wrong was in reading cncusb's publicity that said it was compatible with Vcarve. They didn't mention that only a toolpath file could be read.

While on this topic... I had 2 choices for CNC-USB in saving a toolpath file before I connected the router to the PC. Either inches or metric. Now I've got the whole system functioning, I've got 8 different CNC-USB choices. I tried two of them before resorting to loading Vcarve on my accounting PC (without a router attached) and discovering I could use either provided measurements were in the correct format, use the router.

However... When I go back to the working machine, the item I created with both rounded edges and radius corners is rejected by USB-CNC with an error saying after displaying a whole lot of characters impossible to understand that It is "a Vcarve error". I've tried all the settings (in Vcarve) that have USBCNC in from of them to no avail. I did read where the program opens 'GRBL' files. Have you ever used it this way? I just plain ran out of time with this. All the USB-CNC files Vcarve will save all seem to have .tap extensions except the first one I tried with a .nc extension. I be grateful for a pointer with this issue.
Ryadia
 
Posts: 6
Joined: 15 Apr 2017, 00:34

Re: G-code error when opening Vcarve file

Postby mswrites » 14 May 2017, 13:48

i THINK i'M BEGINNING TO UNDERSTAND YOUR PROBLEM.

1st what kind of controller do you have? Assuming mk3

What kind of CAD do you have? You don't mention any. Since you have Vcarve (I'm assumming Vcarve Pro ver 8.5). Simply put you can do 2d (xy) and 3d (xyz). Therefore you will need a 3d Cad. It can do both. Without it you can just do circles, squares and play. Many available from few to many $$$. It will be the hardest to learn. So get one that has a forum you can ask questions.
A good one (I have it) is MOI3d. See and purchase at MOI3d.com.
Forum is at http://moi3d.com/forum/index.php?webtag=MOI&msg=402.9
Beginning Tutorials at https://www.youtube.com/watch?v=jJd-gSJytTM

From the CAD you make a drawing of an object. Call it a doughnut cutter. You save it as "cutter.dxf"
OPen Vcarve
1/ click create new file 2/click Open 3/ select "cutter.dxf" 4/ select toolpath and click on profile toolpath 5/ select calculate 6/ click save toolpath 7/select post processor (g-code arcs (mm) ( *tap))
(are you working in mm or inches?) 7/save toolpath
load USB CNC
click file open 2/ select profile.tap
select start point
measure tool offset
commence cutting
mswrites
 
Posts: 91
Joined: 14 Jan 2012, 17:15
Location: Sun Lakes, Az
Controller: Mk3

Re: G-code error when opening Vcarve file

Postby mswrites » 14 May 2017, 14:01

in CNCUSB under "file" forget everything from "recent files" down to "settings".
under "settings" i hope you know how to do that
mswrites
 
Posts: 91
Joined: 14 Jan 2012, 17:15
Location: Sun Lakes, Az
Controller: Mk3

G code error when opening Vcarve file

Postby natorEcomi » 25 May 2017, 05:02

I utilize Simplify 3D, and would like when the M2 is done running its prints for the night to automatically shut off. Maybe that is asking to much. However, is there a G code or something software related that could accomplish this?
natorEcomi
 
Posts: 2
Joined: 20 May 2017, 15:20
Location: Россия
Controller: Chinese clone


Return to Software



Who is online

Users browsing this forum: Bing [Bot] and 3 guests