MK3/4 controller doesn't respond to USB

General topics about everything that doesn't fit elsewhere.

MK3/4 controller doesn't respond to USB

Postby Diemesse » 12 May 2017, 19:14

I bought an MK3/4 controller way back in March of 2015, serial numberZ8798. This controller sat for 1-1/2 years as I ended up sidetracked with other projects. I finally got around to setting the CNC up last fall. Everything worked well, the CNC has photo-eye limits, spindle and dust collector start-stop, etc. Worked beautifully.

I then decided to dedicate a different laptop to this CNC, but I forgot to load the drivers first. The laptop saw a new device, and tried to find out what device was on the USB line and failed. I then shutdown, uploaded the USB drivers from Planet-CNC and tried to restart. The controller no longer responds to any USB communications. Matter of fact, the computer doesn't even recognize that something just plugged into the USB port when I plug the controller in.

I tried to re-upload the firmware by crossing out the lowest open jumper positions below RA1 and restarting. The controller responds as expected by rapid LED flashing, but the controller will not respond to anything on the USB. I've switched USB cables, checked grounding, and tried the original computer that it worked with, all to no avail. I've since ordered a new controller and installed it, but I wonder if controller Z8798 is save-able as a spare.

Did I junk this controller by plugging in the USB cable to the computer before the driver was uploaded? Can it be revived?

Posts: 1
Joined: 12 May 2017, 18:30
Controller: Many controllers

Re: MK3/4 controller doesn't respond to USB

Postby Support » 17 May 2017, 10:06

Controller should be revived. You cannot bridge the controller when updating.
Please contact us at
Posts: 2671
Joined: 07 Apr 2014, 17:39
Controller: Many controllers

Return to General topics

Who is online

Users browsing this forum: No registered users and 2 guests