API SendMovePosAxis fails after 25 commands

API SendMovePosAxis fails after 25 commands

Postby adrian » 18 Aug 2014, 07:07

Hello,

I'm facing a problem: after 25 commands, SendMovePosAxis method fails (returns false) and doesn't execute.
I'm reading the buffer size and buffer free, and they return values of 14, respectively 13.
The only way to get out of this blockage is to quit the application and to restart it, initializing again the API, but it takes approximately 15 seconds until initialize function returns true.

Methods are called from LabVIEW, using .NET class constructors and invoke nodes .

Can you help me please with a suggestion, or an advice?

Adrian
adrian
 
Posts: 4
Joined: 26 May 2014, 07:13
Controller: Mk1

Re: API SendMovePosAxis fails after 25 commands

Postby Support » 18 Aug 2014, 08:27

This happens because you do not have license for your controller. Unactivated controllers stop executing code after 25 lines of code. Every controllers needs its own license. License should be purchased.

For more information about license please follow this link:
http://www.planet-cnc.com/faq/license/
Support
 
Posts: 2609
Joined: 07 Apr 2014, 17:39
Controller: Many controllers

Re: API SendMovePosAxis fails after 25 commands

Postby paulrengifo » 28 Sep 2014, 00:27

greetings .
I have the same problem, but the difference is that I have a license registration in USB CONTROLLER CNC program , the controller passes the 25 lines of axis movement , but in my custom application in VB presents the same problem of adrian Please I need your help ..
paulrengifo
 
Posts: 9
Joined: 15 May 2014, 16:03
Controller: Mk1

Re: API SendMovePosAxis fails after 25 commands

Postby stonnedd » 22 Jul 2015, 22:04

i have the License too, with CNC USB controller software i dont have any problem but in my own application i have the same 25 commnands problem.... any solution i really need it
stonnedd
 
Posts: 1
Joined: 22 Jul 2015, 21:36
Controller: Mk2

Re: API SendMovePosAxis fails after 25 commands

Postby Support » 23 Jul 2015, 06:41

.lic file must be located in application folder.
Support
 
Posts: 2609
Joined: 07 Apr 2014, 17:39
Controller: Many controllers


Return to API



Who is online

Users browsing this forum: No registered users and 1 guest